Welcome

LogiSphere Help Seiz System Engineering

Welcome to LogiSphere

Get started
How to...
Settings
Services

Information on the Internet

User Forum
Online documentation

Cameras Online

License

Copyright(c) 2006, Seiz System Engineering


Get started

On the Devices page to configure the webcam device.

  • choose the video device you want to use from the droplist
  • configure video: set picture quality, frame rate and video size
  • check Use Cam to start the camera device

if you own a Logitech Sphere / Orbit camera:

  • Select the Orbit device from the droplist
  • check Use Sphere to activate the device
  • when the device is activated, it makes a 'home' move.
    You can use the test buttons to see if the device is moving as expected.

    If you have multiple Sphere entries, you may have to try a different one until you find the active device

Go to the Options page to configure the web server.

  • check Web Server to start the server

now your server is up and running and you can access the example files on this address:

http://localhost:8080/


How To

  • Request License
  • Ftp Upload
  • Motion detection
  • List your WebCam
  • enable password protection
  • use a TV tuner


How to

LogiSphere Help Seiz System Engineering

How To enable FTP Upload

the cam devices has to be active for ftp upload to work.

Select the Storage page

  • enter ftp access information: ftp server (name or ip), user name and password
  • enter directory, where the files will be uploaded to
  • enter a file name or check time based name

Save options
enter the uploadinterval in seconds

check FTP Active to start the ftp upload

  • use the Test button to see if your settings work.
  • set the Save interval to your needs


How to

LogiSphere Help Seiz System Engineering

How To Motion detection

motion detection can be used for both FTP Upload and Local Save

Select the Storage page and verify your configuration for FTP Upload and / or Local Save

Configure motion detection

  • set trigger level (lower numbers = higher sensitivity)
  • check Motion Detection

check FTP Active and / or Local Save to start motion detection

One shot per interval will be stored, the one with the most motion.
If no motion occured during the save interval, nothing will be saved.

Motion pictures can be replayed as jpeg stream: http://localhost:8080/motion.mjpg
How to use jpeg streams


How to

LogiSphere Help Seiz System Engineering

How To Request a License

  • Free License

    Select the Options page, then click on User and License

    • Enter your full first and last name
    • Enter your email address
    • check Receive Update Info to receive news about LogiSphere by email
    • check Request License to request a free license

    Click on Send Request to process your settings

    • Please make sure you use enter a valid mailbox as you will receive the license by email.
    • A internet connection is required to send your request.
    • Your license request will be answered during european working hours only. Your request will be answered by a human being - be patient.

  • LogiSphere Pro License

    The LogiSphere Pro License is available through electronic payment (PayPal).

    Click on Upgrade to LogiSphere Pro to go to the payment form.

    The LogiSphere Pro License request will be processed automatically and immediately - no need to wait for your license


How to

LogiSphere Help Seiz System Engineering

How To get your camera listed

you may list your WebCam on the LogiSphere WebCam List

Select the Options page

  • check Listed
  • verify URLs for Server, Picture and Camera
  • enter Camera Description
  • check Receive Update Info
    • to receive lincense information

check Web Server to send the request

  • LogiSphere will connect to the server
  • The server will connect back to you to verify your URLs
  • if problems are detected, you will see a Popup Message


How to

LogiSphere Help Seiz System Engineering

How To enable password protection

With password protection, no unauthorized access to the web server is possible.

Select the Options page

Click on the Passwords button

check Protected enable password protection

Passwords and their effective range

  • Main
    all content delivered from the data directory
  • Camera
    image and streams from the video e
  • Tilt/Pan
    Tilt/Pan control URLs
  • Administrator Password
    Web Administration Interface


TV Tuner

LogiSphere supports TV Tuners as video capture device.

Once a TV Tuner is detected, a Tuner button is visible in the Driver Options on the Devices screen. How to set channels:

URL | action
http://localhost:8080/channel=1 | set channel number 1
http://localhost:8080/channel=- | decrease channel number by one
http://localhost:8080/channel=-- | decrease channel number until a signal is detected
http://localhost:8080/channel=+ | increase channel number by one
http://localhost:8080/channel=++ | increase channel number until a signal is detected
http://localhost:8080/channel=+A | increase channel number by one, autotune after changing channel

replace http://localhost:8080/ with your own host / port combination

Autotune

TV channels generally map to a unique frequency depending on regional variances. To avoid interference between multiple transmitters that are assigned the same channel when they are in close geographic proximity, small frequency offsets are introduced at each transmitter. In the United States, this offset ranges up to +/– 26.25 kHz.

Autotune handles the channel-to-frequency conversion and scans for the most precise frequency. Add a A to the change channel URL to activate Autotuning.

tuner.txt

if you don't want to use all channels, or if many of the channels don't have a signal, you can limit the channels to be used.

Create a text file named tuner.txt in the LogiSphere program folder and list all the channels you want to use, one number per line.
When switching channels up or downwards, channels not listed in the file will be skipped.
When tuner.txt exists, both ++ and + (-- and -) will switch to the next channel listed.

Controls

There is a special Server Side Include ( SSI ) which will only have an effect once a TV tuner is active:
<!--#include include tuner -->

It will add this code to the page, once a tv tuner has been detected:
<iframe src="" height="0" width="0" name="tuner" frameborder="0"></iframe>
TV Channel <a href="/channel=++A" target="tuner"><img src="/img/up.gif" border="0"></a>
<a href="/channel=--A" target="tuner"><img src="/img/down.gif" border="0"></a>

in a browser, it will look like this:
TV Channel


Program Settings

The following pages contain information popups information.
Just move your mouse over the screen shot and additional information will be displayed

  • Server Main Screen, switches for services
  • Devices Webcam and Tilt/Pan device settings
  • Options Server Settings
  • Storage FTP Upload, Motion Detection
  • Commands command configuration


Devices

Copyright(c) 2006, Seiz System Engineering


Devices

move the mouse over form elements to get help


Caption

Copyright(c) 2006, Seiz System Engineering


Options

Copyright(c) 2006, Seiz System Engineering


Chat

all changes in this form are effective immediately.

If you press (any) Save button, the owner name, the chat window position and the Log Checkbox status will be saved.

Back to Options


Security

Passwords and their effective range

  • Main
    all content delivered from the data directory
  • Camera
    image and streams from the video device
  • Tilt/Pan
    Tilt/Pan control URLs
  • Administrator Password
    Web Administration Interface


LogiSphere License

LogiSphere Help Seiz System Engineering

LogiSphere License Form

How To request a license License Types


Storage

Copyright(c) 2005, Seiz System Engineering


Email on Motion

Copyright(c) 2006, Seiz System Engineering


Record Video

Video can be started and stopped remotely through the Web Admin Interface on the Status page.


Commands

Assign commands to URLs and execute any command on your computer through a web browser from anywhere


LogiSphere Services

LogiSphere Help Seiz System Engineering

Services

Web Server for static html files, images, mp3 files - web content

Tilt / Pan control Tilt/Pan device

WebCam Server serves pictures and streams from video devices

Screen Capture serves pictures and streams of your desktop

JPEG Streams and how to use them

Windows Media Server stream audio and video

TV Tuner tuner options


Web Server

The built in web server runs on the port you define on the Options page

The server delivers files contained in the Data Directory (default: wwwroot)

Server Side Includes

MIME Types

Admin Interface

Error Documents


Web Admin Interface

LogiSphere can be administrated over the web.

to start the Web Admin Interface, use this link:

http://localhost:8080/server-admin

The Web Admin Interface is protected by a password.

back to Web Server


Webserver: Server Side Includes

LogiSphere Help Seiz System Engineering

Server Side Includes

The web server supports server side includes. Specially formatted text will be replaced with dynamic data.

Enable SSI

By default SSI is enabled for all html documents.
If you want to save a few CPU cycles and parse html files with includes only, edit config.txt and
change AutoSSI = True to AutoSSI = False

If AutoSSI is disabled, only files with an extension of .shtml will be parsed for server side includes.

include files

  • include a file from the local directory
    <!--#include file="myfile.txt" -->
    this will replace the above line with the contents of the file myfile.txt
  • include a file from the webserver root
    <!--#include file="/myrootfile.txt" -->
    this will replace the above line with the contents of the file myrootfile.txt

include web pages

you can include any webpage in yours:

  • <!--#include file="http://www.seiz.ch/ad.html" -->
    this will replace the above line with the contents of the web page http://www.seiz.ch/ad.html

include commands

you can include commands in your web pages:

  • <!--#include exec="dir c:\" -->
    this will replace the above line with the directory listing

include vserver link

the build in Windows Media Server runs on a port unknown to the web page.
To include a link to the multimedia content, use the vserver include:

  • <!--#include vserver -->
    this will replace the above line with the windows media server url (eg mms://localhost:8090)

include frame rates

  • <!--#include framerate-capture -->
    this will be replaced with the frame rate set for the cam device
  • <!--#include framerate-stored -->
    this will be replaced with the replay frame rate

include tuner

  • <!--#include include tuner -->
    this will be replaced with the tuner channel control if a tv tuner is the active video device

conditional includes

For various features of LogiSphere you can define conditional includes. Those will be included or excluded depending on which features of LogiSphere are active.

Tilt/Pan Device

<!--#include start tiltpan -->
this will be shown if a tilt / pan device is active
<!--#include stop tiltpan -->

<!--#include start no tiltpan -->
this will be shown if no tilt / pan device not active
<!--#include stop no tiltpan -->

Zoom

<!--#include start zoom -->
this will be shown if Zoom Min is not equal Zoom Max
<!--#include stop zoom -->

<!--#include start no zoom -->
this will be shown if Zoom Min is equal Zoom Max
<!--#include stop no zoom -->

Chat

<!--#include start chat -->
this will be shown if chat is enabled
<!--#include stop chat -->

<!--#include start no chat -->
this will be shown if chat is disabled
<!--#include stop no chat -->

Tuner

<!--#include start tuner -->
this will be shown if the video device is a TV tuner
<!--#include stop tuner -->

<!--#include start no tuner -->
this will be shown if the video device is no TV tuner
<!--#include stop no tuner -->

Video Server

<!--#include start videoserver -->
this will be shown if the Video Server is active
<!--#include stop videoserver -->

<!--#include start no videoserver -->
this will be shown if the Video Server is not active
<!--#include stop no videoserver -->

to see all these examples in use, check out the html files delivered with LogiSphere

back to Web Server


MIME Types

LogiSphere has definitions for several mime types built in:
  • html htm shtml htm -> text/plain
  • jpg jpeg -> image/jpeg
  • gif -> image/gif
  • jar -> application/java-archive; charset=iso-8859-1
all other file extensions will be delivered as mime type application/octet-stream

If you want to add your own definitions or override on of the settings above,
create a file named mimetypes.txt in the LogiSphere program folder.
define your mime types in this format:
<ext>=<mime-type>

eg.
html=text/plain

The file will be read on program start.

back to Web Server


Error Documents

LogiSphere supports custom error messages for
  • Error 404 File not found
  • Error 401 Authentication required
Create a file named 404.html / 401.html in the server data directory (default c:\progam files\LogiSphere\wwwroot\).

Once the file exists, LogiSphere will show your custom error document instead of the built in one.

back to Web Server


WebCam

The video device can be accessed in several modes.

the following links assume that your LogiSphere is running on the the default port

still picture

<img src="http://localhost:8080/current.jpg">

jpeg stream

<img src="http://localhost:8080/current.mjpg">

video stream in default frame rate and size

windows media stream

<img src="mms://localhost:8090">

streaming video and audio in the selected profile

screen shot

<img src="http://localhost:8080/screen.jpg">

screen shots must be enabled in Options

screen shots as jpeg stream

<img src="http://localhost:8080/screen.mjpg">

stored files as jpeg stream

<img src="http://localhost:8080/motion.mjpg">

Set Video Size and Frame Rate

how to use JPEG Streams


Screen Capture

LogiSphere can show your screen in a single picture or as a stream.

screen shots must be enabled in Options

single screen shot

<img src="http://localhost:8080/screen.jpg">

screen shots as jpeg stream

<img src="http://localhost:8080/screen.mjpg">


Set Video Size and Frame Rate

Video Size and Frame Rate can be set on demand.

Video Size

All video links above support sizing.

just add the size parameter.

Examples:

http://localhost:8080/current.jpg?size=640x480
http://localhost:8080/current.jpg?size=320x240

Frame rate

all JPEG streams can stream at a selectable frame rate. The maximum frame rate is defined for the video device in Devices

To set the frame rate on demand, define the fps parameter.

Examples:

http://localhost:8080/current.mjpg?fps=2
http://localhost:8080/screen.mjpg?fps=0.5
http://localhost:8080/motion.mjpg?fps=15

Selection for replay of stored shots

to filter picture replay, use the filter parameter:

Example:

http://localhost:8080/motion.mjpg?filter=20051019*
this will show pictures taken on Oct 19th 2005 (if pictures were save with time based names)

Combine parameters

to use more than one parameter in a request, combine them using &

Example:

http://localhost:8080/screen.mjpg?size=640x480&fps=1
this will show your desktop sized to 640x480 and refreshed once per second


How to use jpeg streams

LogiSphere supports three different sources of jpeg streams

  • Video Device
    http://localhost:8080/current.mjpg
  • Screen Capture
    http://localhost:8080/screen.mjpg
  • Stored pictures
    http://localhost:8080/motion.mjpg

Many Browsers (eg. Firefox, Safari, Opera) support the display of jpeg streams.

others like IE need the help of a Java Applet to display the stream.

for Java Applets and their use check out

wwwroot/java/readme.txt and the examples in that directory


Tilt/Pan

you can control a Logitech Orbit USB camera with LogiSphere

use the following links:

Directions

direction followed by number of steps

up

http://localhost:8080/up-2

down

http://localhost:8080/down-5

left

http://localhost:8080/left-5

right

http://localhost:8080/right-3

home

http://localhost:8080/home-0

absolute position

http://localhost:8080/pos-pan,tilt

Examples:

http://localhost:8080/pos-1,1 moves to 1, 1

http://localhost:8080/pos--10,-10 moves to -10, -10

http://localhost:8080/pos--10,10 moves to -10, 10

http://localhost:8080/pos-10,10 moves to 10, 10

http://localhost:8080/pos-10,-10 moves to 10, -10

if your LogiSphere is on, you can try the examples above

Please see the example files, wwwroot/javascript/index.html has more examples


Windows Media Server

Configure the built in windows media server on the Options page:

  • Server Port
    choose any port number, make sure it's not the same as for the web server
  • Max. Clients
    maximum number of clients to connect at the same time
  • On Demand
    The video server is constantly compressing video when active. Even with no clients watching, this consumes resources of your computer. To save on resources, check this box. The video server will be started when a client loads http://localhost:8080/current.asx. Whenever there are no more clients, the server will shut down again.
  • Profile
    choose any of the predefined profiles. The server will reduce bandwidth automatically if it's unable to stream at the profile bandwidth selected
  • Audio Device
    Choose a device
  • Audio Channel
    some devices have more than one audio input, select the one you prefer

Access Streaming Video

The video server runs on a different port than the web server.

Use http://localhost:8080/current.asx to load the video stream.
This will redirect to mms://localhost:8090 where the video server is running.

If the video server is off, current.asx will redirect to a static wmv file.

If the video server is set to run on demand only, current.asx will start the video server.


Applets

Applets:

There are a number of Java Applet examples provided by Seiz System Engineering
  • logispherestreaming Motion JPEG video display
  • logiabs Camera control
  • ssechat Simple Java Chat Interface
  • logivideo Single JPEG video display


Applet logispherestreaming

Applet logispherestreaming

provides video with relative motion control

if the video stream ends, the applet will set the hand cursor.
clicking on the applet will restart the video stream

Parameters:

all parameters are optional

<param name="image" value="current.mjpg">
motion jpeg stream to retrieve
default is current.mjpg, set it to motion.mjpg to retrieve stored pictures

<param name="width" value="640">
<param name="height" value="320">
dimensions of the applet, stream will be scaled on the server end

<param name="fps" value="4">
frames per second to retrieve

<param name="baseref" value="http://localhost:8080">
if set, the applet will try to load the stream from that location.
by default the applet will derive the baseref from the document location.

<param name="nosphere" value="true">
use this parameter to disable motion control if you don't own a Logitech Orbit / Sphere

<param name="baserefcam" value="http://localhost:8080">
set location for the motion jpeg stream, image will be appended

<param name="usercam" value="user">
<param name="pwcam" value="password">
set user and password for the motion jpeg URL

<param name="basereftp" value="http://localhost:8080">
set location for tilt / pan, commands will be appended as requested

<param name="usertp" value="user">
<param name="pwtp" value="password">
set user and password for the tilt / pan URLs


Applet logiabs

Applet logiabs

provides absolute motion control with position feedback

every 5 seconds the applet requests the position and displays it using a red dot.
after 3 minutes of inactivity, the red dot will dissapear and the position will not
be requested anymore.

a click on the applet restarts position querying, any click to position will keep it alive

Parameters:

<param name="home" value="http://localhost:8080">
if set, the applet will send requests to that location.
Java Applets can only request content from the server they were loaded from
by default the applet will send requests to the document location.


Applet ssechat

Applet ssechat

provides a simple chat interface for a web user.

if the chat is not enabled, the applet will shut down.
Otherwise it will present a entry field for the users nick name.
Once this nickname is known, the applet will show chat entries, a textbox to enter text, a send button and a start/stop button.

The applet requests new chat lines every 5 seconds and immediately after sending text.

The applet will time out after 2 minutes. Clicking on the Start button it can be restarted. If a user keeps typing text, it won't time out.

Parameter:

<param name="fps" value="120">
how many seconds to wait after the last 'chat send'
before connection times out
by default this is set to 120


Applet logivideo

Applet logivideo

provides relative motion control with single picture requests

this applet can be used if motion jpeg does not work well, e.g. when a proxy in between adds delays.

Parameters:

<param name="image" value="current.mjpg">
jpeg image to retrieve
default is current.jpg

<param name="width" value="640">
<param name="height" value="320">
dimensions of the applet, must correspond with the image delivered

<param name="fps" value="4">
frames per second to retrieve
by default this is set to 4

<param name="nosphere" value="true">
use this parameter to disable motion control if you don't own a Logitech Orbit / Sphere

<param name="baseurl" value="http://localhost:8080">
if set, the applet will try to load the stream from that location.
by default the applet will derive the baseref from the document location.


LogiSphere License

License types

  • No License

    the software will shut down web server, video server and camera after 30 minutes. It will not require a internet connection to run, but it will try to connect to logisphere.seiz.ch whenever the web server is started or stopped. Requires internet connection to request a free license.

  • Free License

    It will not require a internet connection to run, but it will try to connect to logisphere.seiz.ch whenever the web server is started or stopped. If that connection fails, it will behave just like 'No license' and time out after 30 minutes. If the connection succeeds, LogiSphere will run for 6 hours before timing out.

    Acceptable use: Using the free license once per day is fine. If you'd like to keep your camera online all the time, you should purchase the Pro License.

  • LogiSphere Pro License

    When you upgrade to LogiSphere Pro, the software does not require a internet connection unless you want your camera to be listed. Will not time out even if there is no connection to the internet available.

How to get a License