Introduction

 Top Next

Elcomsoft System Recovery (ESR) is a special boot disk (CD of UFD) based on Microsoft Windows Preinstallation Environment (Windows PE). Windows PE is a hardware-independent minimal Windows system that provides limited services based on the Windows Server 2003 kernel, including native support of NTFS file systems without 3rd party software of drivers. With it, you can use the same preinstallation and troubleshooting environment on all of the desktop computers in your company, or on your home computer, and recovery efforts are less time-consuming and more productive.

ESR has the following features and benefits:

· Out-of-the-box solution, no other software is needed -- simply insert the disk and boot from it
· An ability to create USB Flash Drives (UFD) to boot computers that don't have CD or DVD drives
· Based on Windows PE: licensed, industry-standard, 100% compatible with all hardware
· Supports Windows NT 4.0, Windows 2000, Windows XP, Windows Server 2003
· Supports all non-US versions of Windows, multilingual user names and password (UNICODE compliant)
· Complete support of all RAID and SCSI devices (using Windows drivers)
· Detect all Windows operating systems installed on the computer -- just select from the list (or browse for specific Registry files)
· Dump password hashes from SAM/SYSTEM files or Active Directory database, and write them to the text file for further analysis and password recovery
· Get the list of all local user accounts and their properties; highlight Administrator accounts
· Lookup account privileges (except ones set through local or group policies)
· Detect accounts with empty passwords
· Give Administrator privileges to any user account
· Enable/unlock disabled/locked accounts
· Instantly recover passwords for some special/system accounts (like IUSR_, HelpAssistant etc)
· Reset and change passwords for any local accounts
· Backup SAM/SYSTEM files if any changes were made, and restore these files from backup (e.g. after successful logon with new password)


Copyright and license

 Top Previous Next

NOTICE TO USER:

THIS IS AN AGREEMENT GOVERNING YOUR USE OF ELCOMSOFT SOFTWARE, FURTHER DEFINED HEREIN AS "PRODUCT", AND THE LICENSOR OF THE PRODUCT IS WILLING TO PROVIDE YOU WITH ACCESS TO THE PRODUCT ONLY ON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS AND CONDITIONS CONTAINED IN THIS AGREEMENT.

BY OPERATING THE PRODUCT YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT.

This Electronic End User License Agreement (the "Agreement") is a legal agreement between you (either an individual or an entity), the licensee, and ElcomSoft Co.Ltd. and its affiliates (collectively, the "Licensor"), regarding the Licensor's software, as applicable pursuant to a valid license, and/or other related services, including without limitation

a) all of the contents of the files, disk(s), CD-ROM(s), USB flash drives or other media with which this Agreement is provided and including all forms of code, such as source code and object code, (the "Software"),

b) all successor upgrades, modified versions, modified modules, revisions, patches, enhancements, fixes, modifications, copies, additions or maintenance releases of the Software, if any, licensed to you by the Licensor (collectively, the "Updates"), and

c) related user documentation and explanatory materials or files provided in written, "online" or electronic form (the "Documentation" and together with the Software and Updates, the "Product"). You are subject to the terms and conditions of this End User License Agreement whether you access or obtain the Product directly from the Licensor, or through any other source.

For purposes hereof, "you" means the individual person installing or using the Product on his or her own behalf; or, if the Product is being acquired on behalf of an organization, such as an employer, "you" means the organization for which the Product is acquired, then the person accepting this agreement represents hereby that such organization has authorized such person to accept this agreement on the organization's behalf. For purposes hereof the term "organization," without limitation, includes any partnership, limited liability company, corporation, association, joint stock company, trust, joint venture, labor organization, unincorporated organization, or governmental authority.

By accessing, storing, loading, executing, displaying, copying the Product into the memory of a Client Device, as defined below, or otherwise benefiting from using the functionality of the Product ("Operating"), you agree to be bound by the terms and conditions of this Agreement. If you do not agree to the terms and conditions of this Agreement, the Licensor is unwilling to license the Product to you. In such event, you may not Operate or use the Product in any way.

BEFORE YOU START OPERATING THE PRODUCT, PLEASE CAREFULLY READ THE TERMS AND CONDITIONS OF THIS AGREEMENT, AS SUCH ACTIONS ARE A SYMBOL OF YOUR SIGNATURE AND BY STARTING TO OPERATE THE PRODUCT ON YOUR CLIENT DEVICE, YOU ARE CONSENTING TO BE BOUND BY AND ARE BECOMING A PARTY TO THIS AGREEMENT AND AGREE THAT THIS AGREEMENT IS ENFORCEABLE LIKE ANY WRITTEN NEGOTIATED AGREEMENT SIGNED BY YOU. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT DO NOT OPERATE THE PRODUCT ON YOUR CLIENT DEVICE, AS SUCH TERM IS DEFINED BELOW.

For your reference, you may refer to the copy of this Agreement that can be found in the Help for the Software. You may also receive a copy of this Agreement by contacting Licensor at info@elcomsoft.com.

1. Proprietary Rights and Non-Disclosure.

1.1. Ownership Rights. You agree that the Product and the authorship, systems, ideas, methods of operation, documentation and other information contained in the Product, are proprietary intellectual properties and or the valuable trade secrets of the Licensor and are protected by civil and criminal law, and by the law of copyright, trade secret, trademark and patent of the Russian federation, other countries and international treaties. You may use trademarks only insofar as to identify printed output produced by the Product in accordance with accepted trademark practice, including identification of trademark owner's name. Such use of any trademark does not give you any rights of ownership in that trademark. The Licensor and its suppliers own and retain all right, title, and interest in and to the Product, including without limitations any error corrections, enhancements, Updates or other modifications to the Software, whether made by Licensor or any third party, and all copyrights, patents, trade secret rights, trademarks, and other intellectual property rights therein. Your possession or use of the Product does not transfer to you any title to the intellectual property in the Product, and you will not acquire any rights to the Product except as expressly set forth in this Agreement. All copies of the Product made hereunder must contain the same proprietary notices that appear on and in the Product. Except as stated herein, this Agreement does not grant you any intellectual property rights in the Product and you acknowledge that the license granted under this Agreement only provides you with a right of limited use under the terms and conditions of this Agreement. The Product is licensed, not sold.

1.2. Source Code and Modifications. You acknowledge that the source code for the Product is proprietary to the Licensor and constitutes trade secrets of the Licensor. You agree not to modify, or create derivative works based upon the Product in whole or in part nor reverse engineer, decompile, disassemble the source code of the Product in any way unless such activity is expressly permitted by this License agreement.

1.3. Confidential Information. You agree that, unless otherwise specifically provided herein or agreed by the Licensor in writing, the Product, including the specific design and structure of individual programs and the Product, constitute confidential proprietary information of the Licensor. You agree not to transfer, copy, disclose, provide or otherwise make available such confidential information in any form to any third party without the prior written consent of the Licensor. You agree to implement reasonable security measures to protect such confidential information.

1.4. Third party software. The Product contains third party software, Microsoft(R) Windows(tm)Preinstallation Environment (Windows PE). The Product can be used only as a boot, diagnostic, disaster recovery, setup, restoration, emergency services, installation, test and/or configuration utilities program, and not for use as a general purpose operating system or as a substitute for a fully functional version of any operating system product.

1.5. Utility software The Product contains utility software that can be used for creating external bootable disk (such as UFD) with the same functionality as the Software. You can use that disk under the same EULA and it remains the integral part of the Product.

2. Grant of License.

2.1. License. The Licensor grants you the following rights ("License") and you hereby agree and accept such License:

Grant of License. Unless otherwise specifically indicated under a valid license granted by the Licensor, you are granted a non-exclusive and non-transferable license to use one (1) copy of the Product and during the term of your license, subject to the payment of the applicable fees and your compliance with the terms hereof, this Agreement permits you as an individual or any of your employees (in case of an entity) to Operate one copy of the specified version of the Product, for internal purposes only, on unlimited number of computers, workstations, or other electronic devices of which the software was designed (each a "Client Device") within one location.

The Licensor reserves all rights not expressly granted herein.

2.2. Back-up Copies. You can make only one (1) copy of the Product for backup and archival purposes, provided, however, that the original and each copy is kept in your possession or control, and that your installation and use of the Product does not exceed that which is allowed in this Section 2.

2.3. Prohibitions. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this Agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution. Neither ElcomSoft binary code nor source may be used or reverse engineered to re-create the program algorithm, which is proprietary, without written permission of Licensor. All rights not expressly granted here are reserved by ElcomSoft Co.Ltd.

2.4. Transfers. Under no circumstances shall Licensee sell, rent, lease, license, sublicense, publish, display, distribute, or otherwise transfer to a third party the Software, any copy thereof, in whole or in part, without Licensor's prior written consent, unless otherwise provided for in this Agreement.

2.5. Acceptance of Licensing Terms. Using the Product signifies acceptance of these terms and conditions of the License. If you do not agree with the terms of the license you must cease to use the Product.

2.6. Material Terms and Conditions. Licensee specifically agrees that each of the terms and conditions of this Section 2 are material and that failure of Licensee to comply with these terms and conditions shall constitute sufficient cause for Licensor to immediately terminate this Agreement and the License granted under this Agreement. The presence of this Section 2.6 shall not be relevant in determining the materiality of any other provision or breach of this Agreement by either party.

2.7. Term and Termination. The term of this Agreement ("Term") shall begin when you access or operate the Product or pay the applicable license fees (whichever is earlier) and shall continue for the term specified in your order. Without prejudice to any other rights, this Agreement will terminate automatically if you fail to comply with any of the limitations or other requirements described herein. Upon any termination or expiration of this Agreement, you must immediately cease use of the Product and destroy all copies of the Product.

2.8. No Rights Upon Termination. Upon termination of this Agreement you will no longer be authorized to Operate or use the Product in any way.

3. Support and Updates.

3.1. Terms of Support. During the one-year period you are entitled to technical services and support for the Product which is provided to you by Licensor during the regular business hours (GMT+ 03:00), except for locally-observed holidays, and includes the support provided through a special technical support section of the Licensor's site (the "Site") and email support@elcomsoft.com. During such period of one year e-mail support is unlimited and includes technical and support questions and patch fixes.

3.2. Updates. During the one-year period, you may receive Updates to the Product when and as the Licensor makes them available free of charge. You agree to bear all delivery costs of such updates. If the Product is an Update to a previous version of the Product, you must possess a valid license to such previous version in order to use the Update. You may continue to use the previous version of the Product on your Client Device after you receive the Update to assist you in the transition to the Update, provided that:

i) the previous version or copies thereof are not transferred to another party or another party's Client Device unless all copies of the Update are also transferred to such party or Client Device;

(ii) you acknowledge that any modification that you made to the Product may be lost, altered, distorted or destroyed rendering such modifications, Product or the part thereof inoperable or non-usable; and

(iii) you acknowledge that any obligation the Licensor may have to support the previous version of the Product may be ended upon availability of the Update. Nothing in this Agreement shall be construed as to grant you any rights or licenses with regard to the new releases of the Product or to entitle you to any new release. This Agreement does not obligate the Company to provide any Updates. Notwithstanding the foregoing, any Updates that you may receive become part of the Product and the terms of this Agreement apply to them (unless this Agreement is superseded by a succeeding agreement accompanying such Update or modified version of the Product).

4. Restrictions.

4.1. No Transfer of Rights. You may not transfer any rights pursuant to this Agreement nor rent, sublicense, lease, loan or resell the Product. You may not permit third parties to benefit from the use or functionality of the Product via a timesharing, service bureau or other arrangement, except to the extent such use is specified in the application price list, purchase order or product packaging for the Product. Except as otherwise provided in Section 1.2 hereof, you may not, without the Licensor's prior written consent, reverse engineer, decompile, disassemble or otherwise reduce any party of the Product to human readable form nor permit any third party to do so, except to the extent the foregoing restriction is expressly prohibited by applicable law. Notwithstanding the foregoing sentence, decompiling the Software is permitted to the extent the laws of your jurisdiction give you the right to do so to obtain information necessary to render the Software interoperable with other software; provided, however, that you must first request such information from the Licensor and the Licensor may, in its discretion, either provide such information to you (subject to confidentiality terms) or impose reasonable conditions, including a reasonable fee, on such use of the Software to ensure that the Licensor's and its affiliates' proprietary rights in the Software are protected.

4.2. Proprietary Notices and Copies. You may not remove any proprietary notices or labels on the Product. You may not copy the Product except as expressly permitted in Section 2 above.

4.3. Compliance with Law. You agree that in Operating the Product and in using any report or information derived as a result of Operating this Product, you will comply with all applicable international, national, state, regional and local laws and regulations, including, without limitation, privacy, trademark, patent, copyright, export control and obscenity law and you shall not use the Product for unethical or illegal business practices or in violation of any obligation to a third party in using, operating, accessing or running any of the Product and shall not knowingly assist any other person or entity to so violate any obligation to a third party.

4.4. Special Security Feature. The Product contains a security feature that will cause the computer system to reboot without prior notification to the end-user after 24 hours of continuous use.

5. WARRANTIES AND DISCLAIMERS.

5.1. Limited Warranty. The Licensor warrants that within 30 days (the "Warranty Period") after the delivery date (the day when the Product is delivered to you), the media on which Product has been provided will be free from defects in materials and workmanship and that the Software will perform substantially in accordance with the Documentation or generally conform to the Product's specifications published by the Licensor. Non-substantial variations of performance from the Documentation do not establish a warranty right. THIS LIMITED WARRANTY DOES NOT APPLY TO UPDATES AS APPLIED TO ANY MODIFIED PRODUCT, WHETHER OR NOT SUCH MODIFICATION IS PERMISSIBLE HEREUNDER, EVALUATION VERSIONS, UPDATES, PRE-RELEASE, TRYOUT, PRODUCT SAMPLER, OR NOT FOR RESALE (NFR) COPIES OF PRODUCT. This limited warranty is void and your support right terminates if the defect has resulted from accident, abuse, or misapplication or any modification, whether or not such modification is permitted hereunder. No warranty is made as to the integrity, protection or safekeeping of any modification to the Products made by you upon use of any of the Updates. To make a refund or other warranty claim, you shall return the Product within 30 days after the delivery date along with the written explanation of the problem and the proof of transaction to the location where you obtained it. You shall bear all delivery costs. Refund will be made within 30 days after the receipt of the copy of the product by the Licensor. THE LIMITED WARRANTY SET FORTH IN THIS SECTION GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE ADDITIONAL RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION.

5.2. Customer Remedies. The Licensor and its suppliers' entire liability and your exclusive remedy for any breach of the foregoing warranty shall be return of the purchase price paid for the license,

5.3. NO OTHER WARRANTIES. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, AND FOR ANY WARRANTY, CONDITION, REPRESENTATION OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE PRODUCT IS PROVIDED "AS-IS" WITHOUT ANY WARRANTY WHATSOEVER AND THE LICENSOR MAKES NO PROMISES, REPRESENTATIONS OR WARRANTIES, WHETHER EXPRESSED OR IMPLIED, WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE, REGARDING OR RELATING TO THE PRODUCT OR CONTENT THEREIN OR TO ANY OTHER MATERIAL FURNISHED OR PROVIDED TO YOU PURSUANT TO THIS AGREEMENT OR OTHERWISE. YOU ASSUME ALL RISKS AND RESPONSIBILITIES FOR SELECTION OF THE PRODUCT TO ACHIEVE YOUR INTENDED RESULTS, AND FOR THE INSTALLATION OF, USE OF, AND RESULTS OBTAINED FROM THE PRODUCT. THE LICENSOR MAKES NO WARRANTY THAT THE PRODUCT WILL BE ERROR FREE OR FREE FROM INTERRUPTION OR FAILURE, OR THAT IT IS COMPATIBLE WITH ANY PARTICULAR HARDWARE OR SOFTWARE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, LICENSOR DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, INTEGRATION, SATISFACTORY QUALITY OR FITNESS FOR ANY PARTICULAR PURPOSE WITH RESPECT TO THE PRODUCT AND THE ACCOMPANYING WRITTEN MATERIALS OR THE USE THEREOF. SOME JURISDICTIONS DO NOT ALLOW LIMITATIONS ON IMPLIED WARRANTIES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. YOU HEREBY ACKNOWLEDGE THAT THE PRODUCT MAY NOT BE OR BECOME AVAILABLE DUE TO ANY NUMBER OF FACTORS INCLUDING WITHOUT LIMITATION PERIODIC SYSTEM MAINTENANCE, SCHEDULED OR UNSCHEDULED, ACTS OF GOD, TECHNICAL FAILURE OF THE SOFTWARE, TELECOMMUNICATIONS INFRASTRUCTURE, OR DELAY OR DISRUPTION ATTRIBUTABLE TO VIRUSES, DENIAL OF SERVICE ATTACKS, INCREASED OR FLUCTUATING DEMAND, AND ACTIONS AND OMISSIONS OF THIRD PARTIES. THEREFORE, THE LICENSOR EXPRESSLY DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY REGARDING SYSTEM AND/OR SOFTWARE AVAILABILITY, ACCESSIBILITY, OR PERFORMANCE. THE LICENSOR DISCLAIMS ANY AND ALL LIABILITY FOR THE LOSS OF DATA DURING ANY COMMUNICATIONS AND ANY LIABILITY ARISING FROM OR RELATED TO ANY FAILURE BY THE LICENSOR TO TRANSMIT ACCURATE OR COMPLETE INFORMATION TO YOU.

5.4. LIMITED LIABILITY; NO LIABILITY FOR CONSEQUENTIAL DAMAGES. YOU ASSUME THE ENTIRE COST OF ANY DAMAGE RESULTING FROM YOUR USE OF THE PRODUCT AND THE INFORMATION CONTAINED IN OR COMPILED BY THE PRODUCT, AND THE INTERACTION (OR FAILURE TO INTERACT PROPERLY) WITH ANY OTHER HARDWARE OR SOFTWARE WHETHER PROVIDED BY THE LICENSOR OR A THIRD PARTY. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL THE LICENSOR OR ITS SUPPLIERS OR LICENSORS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF DATA, LOSS OF GOODWILL, WORK STOPPAGE, HARDWARE OR SOFTWARE DISRUPTION IMPAIRMENT OR FAILURE, REPAIR COSTS, TIME VALUE OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE PRODUCT, OR THE INCOMPATIBILITY OF THE PRODUCT WITH ANY HARDWARE SOFTWARE OR USAGE, EVEN IF SUCH PARTIES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL LICENSOR'S TOTAL LIABILITY TO YOU FOR ALL DAMAGES IN ANY ONE OR MORE CAUSE OF ACTION, WHETHER IN CONTRACT, TORT OR OTHERWISE EXCEED THE AMOUNT PAID BY YOU FOR THE PRODUCT. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT THAT APPLICABLE LAW PROHIBITS SUCH LIMITATION. FURTHERMORE, BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU. MICROSOFT AND MICROSOFT AFFILIATES DISCLAIM ALL LIABILITY WHATSOEVER RELATED TO MICROSOFT SOFTWARE USED IN THE PRODUCT (MICROSOFT WINDOWS PREINSTALLATION ENVIRONMENT) AND THE PRODUCT ITSELF.

6. Indemnification

6.1. Indemnification for Violations. Your Operating of the Product, your accessing your account with Licensor and your entering into this Agreement constitutes your consent and agreement to defend, indemnify and hold harmless Licensor and its affiliated companies, employees, contractors, officers and directors from any claim or demand, including reasonable attorney's fees arising out of your use of the Product in violation of this Agreement. SPECIAL PROVISION APPLICABLE TO U.S. PERSONS AND ENTITIES.

7. U.S. Government-Restricted Rights.

7.1. Notice to U.S. Government End Users. The Product and accompanying Documentation are deemed to be "Commercial Items," as that term is defined at 48 C.F.R. par. 2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," respectively, as such terms are used in 48 C.F.R. par. 12.212 or 48 C.F.R. par. 227.7202, as applicable. Consistent with 48 C.F.R. par. 12.212 or 48 C.F.R. par. 227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights, including any use, modification, reproduction, release, performance, display or disclosure of the Product and accompanying Documentation, as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States.

7.2. Export Restrictions. You acknowledge and agree that the Product may be subject to restrictions and controls imposed by the Export Administration Act and the Export Administration Regulations of the United States (the "Acts"). You agree and certify that neither the Product nor any direct product thereof is being or will be used for any purpose prohibited by the Acts. You may not Operate, download, export, or re-export the Product (a) into, or to a national or resident of, any country to which the United States has embargoed goods, or (b) to anyone on the United States Treasury Department's list of Specially Designated Nationals or the U.S. Commerce Department's Table of Deny Orders. By downloading or using the Product, you are representing and warranting that you are not located in, under the control of, or a national or resident of any such country or on any such list. You acknowledge that it is your sole responsibility to comply with any and all government export and other applicable laws and that the Licensor has no further responsibility for such after the initial license to you. You warrant and represent that neither the U.S. Commerce Department, Bureau of Export Administration nor any other U.S. federal agency has suspended, revoked or denied your export privileges.

8. Your Information and the Licensor's Privacy Policy

8.1. Privacy Policy. You acknowledge receipt of and agree to the Licensor's privacy statement which is made available to you in connection with the use of the Product and is set forth in full at http://www.elcomsoft.com/privacy.html. You hereby expressly consent to the Licensor's processing of your personal data (which may be collected by the Licensor or its distributors) according to the Licensor's current privacy policy as of the date of the effectiveness hereof which is incorporated into this Agreement by reference. By entering into this Agreement, you agree that the Licensor may collect and retain information about you, including your name and email address. The Licensor employs other companies and individuals to perform certain functions on its behalf. Examples include fulfilling orders, delivering packages, sending postal mail and e-mail, removing repetitive information from customer lists, analyzing data, providing marketing assistance, processing credit card payments, and providing customer service. They have access only to personal information needed to perform their functions, but may not use it for other purposes. The Licensor publishes a privacy policy on its web site and may amend such policy from time to time in its sole discretion. You should refer to the Licensor's privacy policy prior to agreeing to this Agreement for a more detailed explanation of how your information will be stored and used by the Licensor. If "you" are an organization, you will ensure that each member of your organization (including employees and contractors) about whom personal data may be provided to the Licensor has given his or her express consent to the Licensor's processing of such personal data. Personal data will be processed by the Licensor or its distributors in the country where it was collected.

8.2. Public Announcements. The Licensor may identify you to the public as a customer of the Licensor and describe in a customer case study the services and solutions delivered by the Licensor to you. The Licensor may also issue one or more press releases, containing an announcement of the execution and delivery of this Agreement and/or the implementation of the Product by you. Nothing contained in this Section shall be construed as an obligation by you to disclose any of your proprietary or confidential information to any third party. In addition, you may opt-out from this Section by writing an opt-out request to the Licensor at info@elcomsoft.com.

9. Miscellaneous.

9.1. Governing Law; Jurisdiction and Venue. This Agreement shall be governed by and construed and enforced in accordance with the laws of the Russian Federation without reference to conflicts of law rules and principles. To the extent permitted by law, the provisions of this Agreement shall supersede any provisions of the Uniform Commercial Code as adopted or made applicable to the Products in any competent jurisdiction. This Agreement shall not be governed by the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly disclaimed and excluded. The courts within the Russian Federation shall have exclusive jurisdiction to adjudicate any dispute arising out of this Agreement. You agree that this Agreement is to be performed in the Russian Federation and that any action, dispute, controversy, or claim that may be instituted based on this Agreement, or arising out of or related to this Agreement or any alleged breach thereof, shall be prosecuted exclusively in the courts in of the Russian Federation and you, to the extent permitted by applicable law, hereby waive the right to change venue to any other state, county, district or jurisdiction; provided, however, that the Licensor as claimant shall be entitled to initiate proceedings in any court of competent jurisdiction.

9.2. Period for Bringing Actions. No action, regardless of form, arising out of the transactions under this Agreement, may be brought by either party hereto more than one (1) year after the cause of action has occurred, or was discovered to have occurred, except that an action for infringement of intellectual property rights may be brought within the maximum applicable statutory period.

9.3. Entire Agreement; Severability; No Waiver. This Agreement is the entire agreement between you and Licensor and supersedes any other prior agreements, proposals, communications or advertising, oral or written, with respect to the Product or to subject matter of this Agreement. You acknowledge that you have read this Agreement, understand it and agree to be bound by its terms. If any provision of this Agreement is found by a court of competent jurisdiction to be invalid, void, or unenforceable for any reason, in whole or in part, such provision will be more narrowly construed so that it becomes legal and enforceable, and the entire Agreement will not fail on account thereof and the balance of the Agreement will continue in full force and effect to the maximum extent permitted by law or equity while preserving, to the fullest extent possible, its original intent. No waiver of any provision or condition herein shall be valid unless in writing and signed by you and an authorized representative of Licensor provided that no waiver of any breach of any provisions of this Agreement will constitute a waiver of any prior, concurrent or subsequent breach. Licensor's failure to insist upon or enforce strict performance of any provision of this Agreement or any right shall not be construed as a waiver of any such provision or right.

9.4. Contact Information. Should you have any questions concerning this Agreement contact us at legal@elcomsoft.com.

(c) 2006 ElcomSoft Co.Ltd. All rights reserved. The Product, including the Software and any accompanying Documentation, are copyrighted and protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties.


Contacting us

For technical support, please contact us through the web form located at:

http://www.crackpassword.com/support/support.php

For all other requests (general questions, sales, legal), please use another form:

http://www.elcomsoft.com/company.html

Our fax numbers:

+1 866 448-2703 (US and Canada, toll-free)

+44 870 831-2983 (UK)

+49 692 557-7249 (Germany)

Please write in English language only.


Requirements and limitations

· The size of Windows PE (about 120 MB) makes it possible to load the entire Windows PE operating system image into random access memory (RAM), and to start the computer from a RAM disk. The RAM disk boot feature provides a virtual CD file system in memory. This virtual CD is treated as Read Only; Windows PE assigns X as the drive letter of any media that it boots from, and the assignment cannot be modified.
· A minimum of 256 MB of RAM
· The product allows to view/change local user accounts only.
· If you use ESR on the server that is running Active Directory, you can only view the AD user accounts, but cannot change their properties or passwords yet. You can, however, dump password hashes of AD accounts (from AD database: ntds.dit) into the text file (ANSI or UNICODE) for further analysis/recovery in other software like Proactive Password Auditor.
· Some computers may require 3rd party mass-storage drivers (RAID, SCSI, SerialATA etc). You can use the F6 option to add mass-storage devices when starting Windows PE (you will have to supply the floppy disk with the drivers).
· When you boot from the CD, you cannot save password hashes back to the disk, but only to the hard drive.
· Some brand-name notebooks (such as Sony, ASUS, Toshiba etc) with pre-installed operating system may use special built-in user accounts, and if you change their properties or passwords with the ESR, you still may not be able to log on.

There are also some special requirements for booting the computer from UFD (USB Flash Drive), as defined by Microsoft for Windows PE:

· The size of the UFD cannot be smaller than 128 megabytes.
· The size of the UFD cannot be larger than 32 GB.
· The UFD must report a drive type of Removeable, not Fixed.
· The UFD must be first in the list of boot devices in the computer BIOS.
· The computer BIOS must support the extended INT 13h (xINT13) BIOS interrupt for UFDs.
· The computer BIOS must support booting from UFDs.
· The computer's USB controller must support bulk-only transport (BOT).
· The computer must use the x86 architecture. The x64 and Itanium architectures are not supported.

ESR has been designed for maximum compatibility and should be able to boot even from external hard disk (USB or FireWire), but some restrictions still apply.


How to create a bootable UFD

Start the ESRBOOT utility (from ESR CD) and follow a few simple steps to create a bootable UFD:

· Accept the ElcomSoft end user license agreement
· Attach the removable device you would like to format as a bootable disk (warning: all data on this disk will be deleted!)
· Select the disk from the List of drives drop-down box. It is recommended to have an option Show compatible devices only enabled; you may wish to switch it off only if ESRBOOT does not show your removable disk while you're sure you can boot from it.
· The program verifies that the given disk can be configured to boot ESR; creates a special partition; creates a logical drive; formats the drive; makes this drive bootable; copies the ESR files (Windows PE and ESR itself):


Booting from the CD or UFD

To boot your computer from ESR CD, you should setup you BIOS to have the CD-ROM drive as the first device in the list:

Then, simply insert the ESR CD and reboot. You will see the Press any key to boot from CD message:

Simply press any key (such as <Space> or <Enter>), and ESR will start booting (creating the RAM drive and loading Windows PE):

When Windows PE is started, you may need to specify additional mass-storage drivers:

If you boot from the UFD (see How to create a bootable UFD), the steps are generally the same. You will just have to setup your BIOS to boot from the USB device first (not the CD); also, there will be no Press any key... message during boot process.


Database source and working mode

Select the following options:

Program interface language

Accounts database source

· Work with local computer accounts (SAM)
· Work with Active Directory accounts (ntds.dit)

Working mode

· Change account password and properties
· Dump password hashes for further audit/recovery
· Restore Registry or AD from backup

Accounts database source allows to select between local and Active Directory accounts. Please note that to work with AD, you should use ESR on the server (domain controller) running Windows 2000 Server, Windows 2000 Advanced Server or Windows Server 2003.

If you already changed some account properties or password(s) and would like to rollback the changes, select the last option: Restore Registry or AD from backup (you will be prompted for locations of backup copy of SAM or AD database). Otherwise, select Change account password and properties (to change/reset passwords to user accounts, unlock disabled or locked accounts etc), or Dump password hashes ..., if you would like just to dump password hashes from AD or local SAM into the text file for further analysis/recovery in other software like Proactive Password Auditor.

When you dump local password hashes (from SAM), password history hashes are also extracted (and saved into the dump file).

Password hashes can be saved (into the "standard" dump) file in ASCII or UNICODE character set. After dumping, the program asks would you like to open that file in the Notepad; please note that if the user names or comments use non-US alphabet, they will be shown correctly only in UNICODE (and in ASCII dump file, you may see just the asterisks).


Select operating system or SAM/AD files location

Once you have selected the database source (SAM or AD) and working mode (task), you will be prompted for the operating system to work with. With the Auto selection, you just select the system folder from the drop-down box:

With Manual selection, you have to select either the location of the AD database and SYSTEM Registry file (using [...] button at the right):

or the location of SAM and SYSTEM files:

In manual mode, it is recommended to select the location of SYSTEM file first, so the location of SAM (or AD database) will be inserted automatically. The default location of SAM and SYSTEM files is:

%WINDOWS%\SYSTEM32\CONFIG\

And AD database (ntds.dit) is usually stored in the following folder:

%WINDOWS%\NTDS\

When browsing for SAM/SYSTEM/AD files, if you don't see the local drive(s), that means that you do not have necessary drivers (such as SerialATA, SCSI, RAID etc) installed. You may need to specify them during boot process (see Booting from the CD or UFD chapter for details).

Please note that if your system uses non-default SYSKEY mode (i.e. SYSKEY is not stored in the Registry), then the program will prompt you for startup password or SYSKEY floppy disk. If you do not supply them, password hashes cannot be extracted (decrypted), and so you will not be able to change account passwords or properties, or even dump password hashes into the text file.


Local user accounts

If you work with the local (SAM) accounts, you get the list of all local accounts after selecting the operating system or SAM and SYSTEM files:

The accounts that has Administrator rights (privileges) are highlighted with the green color, and the accounts that are locked or disabled are colored with red. Simply select the account you want to change the password or properties for, and press Next; and you will get a detailed information about it:

Here you can reset/change the password as well as the following account properties:

· Administrator account
· Password never expires
· Password expired
· Account disabled
· Account is locked out

After you make necessary changes, press Apply. You will be prompted for location and name of backup copy of SAM database.

It is NOT recommended to just reset the password (set the empty password as a new one) -- instead, select the new (complex) password for security reasons. Please also note that the local security policy may be applied, and so while you're able to set any (even empty) new password, you might not be able to log on with that new password if it does not comply the password policy. Finally, you cannot give Administrator privileges to built-in accounts such as Guest; it is also not recommended to change the password or any properties for any accounts in Guests user group.


AD acounts

 Top Previous

If you work with Active Directory accounts, you will get a list of all Active Directory accounts along with their IDs, as well as the password policy:

Select the account you want to work with, set the new password (according to password policy), and press Set.

Note: this feature is not available in current version of Elcomsoft System Recovery.