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DoInventory™ Quick Start Documentation 
 
 
Introduction: 
 
DoInventory™ allows easy management of your home or business inventory or assets collection from 
any Palm OS® handheld, Pocket PC or Windows Mobile handheld, and Windows PC. The Plus 
version includes PC desktop companion software with additional features. The Lite version runs only 
on Palm OS® handheld computers, and is intended primarily for Mac users. This document provides 
information on the handheld software, as the PC software has its own complete help file system. You 
may want to print this document for easier reference. The handheld screenshots are taken from a 
Palm OS® handheld, but they look almost identical on the Pocket PC. 
 

Installation: 
 
To install the Plus version on a PC, download the setup file.  If this file is in ZIP format, you will need 
to first unzip the file with an unzip utility. Then, double click the .exe setup file to start the PC installer. 
The installer will install both PC and handheld software components. Palm OS® users will need to 
hotsync once the installer is finished to install the handheld files to your handheld. 
 
To install the Lite version, simply download the ZIP file to your PC.  Then, unzip the file with an unzip 
utility such as Winzip (www.winzip.com).  Once unzipped, install all *.prc and *.pdb files to your 
handheld using the Install Tool that was installed with your handheld desktop software. 
 

Registration: 
 
The software is initially installed as a trial version. After purchasing, a 5-digit registration code is 
provided. This 5-digit code is entered in the blank area on the startup screen on the handheld or on 
the PC software from the Help menu. Once the registration code is entered the handheld, tap 
Register. For Palm OS®, on the next hotsync, the registration code will be transferred to the PC. The 
Plus version, if installed, will detect this code and unlock the full PC version. The registration code 
unlocks the full version features. No additional installation is required. 
 

Getting Started: 
 
The following screens and descriptions explain many of the features in DoInventory™. The software 
was designed to be easy and intuitive, so it will be easy to get started. This documentation will help 
explain some of the advanced features. 
 
To start the software on the handheld, tap the DoInventory™ icon. On Palm OS® handhelds, this icon 
may be in the Unfiled category. From the Home (icon) screen on your handheld, tap the drop down list 
in the upper right corner, then select Unfiled to list an uncategorized icons. A category can be 
assigned to the icon to make it easier to find. Consult your handheld manual for how to categorize 
icons. On Pocket PC handhelds, tap the Start menu icon in the upper left, then select Programs from 
the list displayed.  The DoInventory icon will be available from that screen of icons. 
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DoInventory List Screen: 
 

 

Upon startup, the list of records is displayed.  From this screen, the user 
may scroll through the list with the onscreen scrollbar or the hardware 
scroll buttons.  Tap a letter in the Quick Nav Bar to go to the first record 
starting with that letter. Also, the Quick Find Area can be used to jump to a 
certain record by entering the first few letters in the record title. Simply tap 
any record in the list to view the record’s details. 
 
The buttons at the bottom of this screen will create a new blank record, 
filter (search) for certain records, or switch to scan mode allowing barcode 
scanner use. 

 

Record Details Screens: 
 

 
 
 

 

The View screen is displayed after selecting any record in the list. It 
displays the detailed view of any record in a single text box. Empty fields 
are not displayed for a more compact view. 
 
Tap Edit to edit any details for that record. On the Edit screen, simply enter 
the text for each field.  You can easily move to the next field while entering 
data using the Enter key or graffiti stroke (/). 
 
The Expanded Input button to the right of the description field can be used 
to display multiple lines for easier viewing and editing of the corresponding 
text. 
 
The category and location can be changed by tapping the down arrow next 
to the category or location fields. 
 
The five custom field names can be changed by tapping the down arrow to 
the left of any of the custom fields. The list of custom field labels can be 
edited and customized. This allows individual records to be setup precisely 
for a particular item. 
 
Finally, the buttons at the bottom of the screen will save the record, 
duplicate the record, delete the record, or add a note to the record. 

 
Editing Categories, Locations, and Custom Field Names: 
 

 

 

 

The master list of categories, locations, or custom field names can be 
edited to include the names preferred by each user. 
 
To edit the master lists, choose the Edit List… item in the appropriate drop 
down list, or choose the desired option from the File menu. 
 
The screen displayed will list all items in that master list. Icon buttons on 
this screen will add a new item, delete the selected item, or edit the 
selected item. 
 
When an item is edited, the Add button changes to Update, and the Edit 
icon changes to a Clear icon. If you no longer wish to edit the item, tap the 
Clear icon to get out of edit mode. 
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Barcode Scanner Support: 
 

 

 

 

Many types of barcode scanners are supported, including the Symbol 
SPT15xx, 17xx, 18xx, and CSM150 (springboard), the Socket SDIO In-
Hand scanner (for Palm OS or Pocket PC), and any barcode scanner 
supported by SerialMagic™ Professional for Palm OS from Serialio.com 
which include LaserChamp and Socket CHS7 scanners. 
 
To use a barcode scanner, tap the Scan button from the main list screen.  
On the Scan screen, options can be selected to increment/decrement 
inventory counts, view or edit the record matching the scanned barcode, or 
add a new record if no record exists with that barcode. Specify which field 
the barcode is in so that DoInventory can lookup the scanned barcode 
properly. 
 
If a match is found, the Item name and Quantity fields (after +1 or –1 if 
chosen) are displayed.  Further changes to the quantity can be made with 
the buttons to the right of the quantity value. 
 
To edit or view all information for a record after a match is found, tap the 
Edit or View buttons at the bottom of the screen. 
 
Palm Scanners 
The Socket SDIO In-Hand scanner will need to be configured with the 
SocketScan utility. Make sure that the scanner is enabled, then in the 
Configuration portion of the utility, make sure that [CR] is specified as the 
Suffix. Finally, select a hardware Scan Trigger Button to be used. In 
DoInventory, press the selected trigger button to initiate the scan. 
 
Scanners supported by Serial Magic™ Professional for Palm OS by 
Serialio.com: SerialMagic™ will need to be installed and started on the 
Palm OS handheld. Also, the Actions screen will need to be set to: 
<<DATA-IN>><<CR>>. Scanning using any supported scanner will cause 
the record viewer to be displayed with the matching record. The user may 
need to specify the correct Barcode field from the Scan screen in 
DoInventory, if the barcode is not in the item field. 
 
The Symbol CSM-150 springboard scanner for Handspring handhelds will 
need to have the scan trigger button configured. Start the CSM Hello app 
on the handheld, then tap Select Triggers. Pick a hardware button to 
trigger the scanner. In DoInventory, press the selected trigger button to 
initiate the scan. 
 
The Symbol SPT 15xx, 17xx, and 18xx scanners will not need any special 
configuration. 
 
Pocket PC Scanners 
For using the Socket SDIO In-Hand scanner, the SocketScan software will 
need to be installed to the Pocket PC. Once installed, specify a button to 
trigger the scan by going to Start… Settings… Buttons… and assigning 
‘SocketScan’ to the desired button. In DoInventory, press (and release) the 
selected trigger button to initiate the scan. 
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Setting or Changing the Preferences: 
 

 
 

 
 

 

The Preferences screens allow many options to be set by the user. Select 
the Preferences item from the Edit menu to access the preferences 
screens. 
 
Preferences - Page 1 
The default sort can be specified. This is the sort used when the program 
is started on the handheld or PC. 
 
Sorts can be enabled (checked) or disabled (unchecked). Only enable the 
sorts that you want in order to save RAM and improve program speed. 
 
Additional options allow the backup of databases on a hotsync to be 
enabled or disabled (Palm OS handhelds only). The confirmation 
messages when deleting or copy a record can also be enabled or disabled. 
 
Preferences – Page 2 
The default currency symbol can be specified. Enter the desired currency 
symbol into the text area. 
 
Default custom field labels can be specified. These default labels will be 
automatically used for the custom fields anytime a new record is created 
on the handheld or PC. 
 
The date format and separator can be specified on this screen as well. 
 
Password 
Tap the Password button on either preference screen to set or change the 
program password. This password will be required on the handheld and 
PC when starting the software. 

 

Filtering (Searching) Records: 
 

 

Records can be filtered (searched) by first tapping the Filter button on the 
main list screen.  This will display the Filter screen. 
 
Enter the desired search criteria, and tap the Do Filter button to filter on the 
criteria.  A list of records matching the filter will be displayed. 
 
When a filtered list of records is displayed, the Filter button on the main list 
screen will change to an All button.  Tap the All button to clear the filter and 
view all records. 
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Menu Options: 
 

A menu system is available to perform additional functions on the handheld. To view the menu 
system, tap the Menu silkscreen icon (just below the Home silkscreen icon). Also, on most handhelds, 
the title bar for the application can be tapped while the application is running to display the menu 
system. 
 
File Menu:  
 
The File menu offers the following options: 
Edit Category List – selecting this option will display the screen to allow 
the user to edit the master list of categories. 

Edit Location List – selecting this option will display the screen to allow 
the user to edit the master list of locations. 

Edit Custom Field List – selecting this option will display the screen to 
allow the user to edit the master list of custom field names. 

Clear All Quantities – clears quantity values for all records. This is useful 
before doing an inventory count. 

Calculate Summary – calculates a summary of the inventory database, 
including a total item count, total cost, and total value for all records. 

 
 

 

 

 

Edit Menu:  
 
The Edit menu offers the following options: 
Preferences – selecting this option will display the preferences screen to 
allow program settings and a password to be changed. 

Export Record to Memo/Note – while viewing any record, select this 
option to export the record as text to a new memo (Palm OS®) or note 
(Pocket PC). 

Beam Record – (Palm OS® only) – while viewing any record, select this 
option to beam the current record to another DoInventory™ user. 
When the receiving user starts DoInventory™ on their handheld 
again, the new record will be imported. 

Cut/Copy/Paste – standard functions. 
On Screen Keyboard – (Palm OS® only) – displays the Palm OS on-
screen keyboard 

 
 

 

 

Help Menu:  
 
The Help menu offers the following options: 
Help – selecting this option will display the help file available on the 
handheld. 

About – selecting this option will display the About screen, including the 
version number. 

Register – (Pocket PC only) - selecting this option will display the 
Registration screen for entering the registration code. 

Close – (Pocket PC only) - selecting this option will shutdown the 
application on the Pocket PC, rather than hide it. 
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DoInventory Desktop: 
 

The Plus version includes PC desktop software to manage information from the PC. The PC software 
includes all of the features on the handheld software, plus other features specific to the desktop 
software. Features available only on the desktop software include printing selected records, printing 
all records, attaching graphics or pictures to records, importing records from delimited text files (CSV, 
etc.), exporting records to a CSV file, and more. Consult the help file on the PC desktop software for 
further information on the desktop features. 
 

 
 

 
Conclusion: 
 
If you are just evaluating or have already purchased DoInventory™ – Thanks! 
 
If you have questions about the software, or cannot find an answer to a problem at our site, please 
email our support staff. We will work hard to resolve your issue and answer your questions. 
 
 

 
 


